Bitbean User Friendly Forum

Command line wallet for VPS server?

append delete DavidAnthonyNix

I will be traveling soon and moving address between countries, and I was wondering if there is a command line version of the Bitbean wallet so I can easily manage and stake my coins on a VPS.

Reply RSS

Replies

append delete #1. viparmenia

Get the source code and Compile it on VPS.

If you have an Ubuntu VPS following is quick HowTo

sudo apt-get update && apt-get upgrade
sudo apt-get install libboost-all-dev
sudo apt-get install libssl-dev
sudo apt-get install libdb++-dev
sudo apt-get install libminiupnpc-dev
sudo apt-get install p7zip
##!!!##Check for lates Source on Github or Bitbean.org/downloads/
wget http://www.bitbean.org/downloads/BitBeanSourceV1100RC.7z
p7zip -d BitBeanSourceV1100RC.7z
cd BitBeanSourcev1100RC/src/
make -f makefile.unix USE_UPNP=1
strip BitBeand
cp BitBeand /bin/
nano BitBean.conf
##!!!##Following are the lines to be puted into BitBean.conf
server=1
daemon=1
rpcuser=!!anythingyoulike!!
rpcpassword=!!somecomplicatedpasswordyou!!
rpcallow=127.0.0.1
paytxfee=0.1
txindex=1
stake=1

#######Save the Conf fiel and star BitBean by following command####
BitBeand

###########And some usefull commands
BitBeand getinfo
BitBeand getblockcount
BitBeand getstakinginfo
BitBeand getpeerinfo
BitBeand getinfo
###########Unlock Wallet for 4 Years only for Staking
BitBeand walletpassphrase !!yourpasswordforthewallet!! 123456789 true

BitBeand stop

:: @viparmenia added on 09 Sep ’17 · 16:23

Also important to encrypt the wallet using

BitBeand encryptwallet !!yourwalletpassword!!

append delete #2. Rocco

Doesn't seem to be working for me. Blockchain is synced, balance confirmed, wallet unlocked, but:

$ ./BitBeand getsproutinginfo
{
"Enabled" : true,
"Sprouting" : false,
"Errors" : "",
"Current Block Size" : 1000,
"Current Block Tx" : 0,
"Pooled Tx" : 0,
"Difficulty" : 2.98058679,
"Search Interval" : 1,
"Weight" : 0,
"Net Sprout Weight" : 237479203,
"Expected Time" : -1
}

append delete #3. viparmenia

Rocco, are you sure that you have unlocked the wallet for sprouting?
It says Sprouing false

Try to run again the command
BitBeand walletpassphrase !!yourpasswordforthewallet!! 123456789 true

And put the real passwort instead of "!!yourpasswordforthewallet!! " ;)

append delete #4. viparmenia

One more useful command

BitBeand listtransactions | grep timere | awk '{print strftime("%c",$3)}'

append delete #5. whitebeard

I recommend against USE_UPNP=1 in the make command. UPNP has been demonstrated to have vulnerabilities. Replace it with USE_UPNP=- or don't have it at all the default is to have UPNP off.

Also the paytxfee=0.1 in the conf file is a bit high. 0.01 is the minimum. Of course, you can pay whatever you like. Keep in mind that if you set the paytxfee too low and you end up trying to send a really large transaction (kbytes) you may have to make an adjustment to get it to go through.

Reply

(Leave this as-is, it’s a trap!)

There is no need to “register”, just enter the same name + password of your choice every time.

Pro tip: Use markup to add links, quotes and more.

Your friendly neighbourhood moderators: Bitbeaner, Tuwie